웹서버와 데이타베이스 서버가 한대에 같이 있으면 문제 발생소지가 적지만, 만약 따로 있다면 해당 서버끼리는 통신을 해야한다.


하지만 이 경우에 MDAC라는게 의외로 사용되는데,

이 경우에서 보면 데이타베이스 서버의 MDAC보다 웹서버의 MDAC 버전이 같거나 높아야 한다.

만약! 데이타베이스 서버가 윈도2003이고 웹서버가 윈도2000이라고 하면 윈도2003의 기본 MDAC 버전이 더 높기때문에, 웹서버에서 데이타베이스 서버로의 접속은 불가능해진다.

결론 : 웹서버와 데이타베이스 서버의 통신에 이상이 있을 경우 MDAC 버전도 체크하고 업그레이드 해주자!
최신 MDAC는 2.8 SP1이다. 2.8에는 치명적인 버그가 있기 때문에 반드시 패치해주기 바란다.

참고 : MDAC 버전 확인 방법 바로가기




Name __

Password __

Link (Your Website)

Comment

SECRET | 비밀글로 남기기